Windows 11 Issue

Discussion, questions and support.
saratojo
Posts: 12
Joined: Mar 8th, ’19, 22:20

Post by saratojo » Jan 16th, ’22, 16:51

There is an issue in Windows 11 when using <alt><tab> to switch between applications. It is documented here.

When alt-tabbing between an application and a Microsoft Office application (such as Word or Excel), the Word or Excel application frequently comes back into focus as if you had already entered an <alt> to activate the menu line. Since it shouldn't do that, when you start typing as you normally would, you don't input as usual but rather do strange things since the app is now expecting you to use a menu line item. This is extraordinarily annoying.

It was suggested that disabling system tray apps using hotkeys might resolve that problem. Indeed, the problem goes away if I exit the FastKeys program. I have had to disable FastKeys from starting when Windows starts because the problem described above is intolerable.

While I know that this issue is probably a Windows 11 issue, my confidence in Microsoft finding and implementing a fix is low. I am wondering is FastKeys can do something to eliminate the apparent conflict. Until the problem is somehow resolved, I am unable to continue using FastKeys.
Last edited by saratojo on Jan 16th, ’22, 23:14, edited 1 time in total.
User avatar
Marko
Posts: 1461
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jan 16th, ’22, 20:22

Thanks for reporting this, we will certainly take a look.
saratojo
Posts: 12
Joined: Mar 8th, ’19, 22:20

Post by saratojo » Jan 16th, ’22, 23:27

I tried starting FastKeys again and turned off the check marks on the Office products in the Start Menu section.
This seems to have stopped the problem and I am running FastKeys regularly again.
Not sure why they should cause the problem, but whatever works works. ;)
saratojo
Posts: 12
Joined: Mar 8th, ’19, 22:20

Post by saratojo » Jan 17th, ’22, 04:36

Nope. That didn't work. I had to completely turn off FastKeys to get <alt><tab> to work correctly.
User avatar
Marko
Posts: 1461
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jan 17th, ’22, 09:39

We have tested it on our Windows 11 computers today and everything seems to be running as expected. Alt-Tab behavior in Word and Excel (Office 2010) while FastKeys is running is normal. Could you make a list of steps to reproduce this?
saratojo
Posts: 12
Joined: Mar 8th, ’19, 22:20

Post by saratojo » Jan 18th, ’22, 21:18

Excel 2010 running
Another app running.

<alt><tab> from excel to the other app
<alt><tab> back to excel

It goes back and forth between apps just fine.
But lots of times, when you <alt><tab> back to excel, excel becomes active with the menu key active - as if you executing an <alt> while in excel.
User avatar
Marko
Posts: 1461
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jan 20th, ’22, 15:48

I tried to toggle between Excel 2010 and various applications with Alt+Tab many times and could not reproduce it.
It must be something else, have you tried to set FastKeys Preferences to defaults and change the shortcuts?
saratojo
Posts: 12
Joined: Mar 8th, ’19, 22:20

Post by saratojo » Jan 30th, ’22, 04:19

Sorry, I've tried about everything. The only solution to my problem is to exit FastKeys.
saratojo
Posts: 12
Joined: Mar 8th, ’19, 22:20

Post by saratojo » Jan 30th, ’22, 15:14

Rather then exiting FastKeys, I am now pausing it.
Pausing it makes the problem go away.

Edit:
I have further found that if I deselect tab as as option in Preferences, general appearance and in text expander, then the problem goes away.
User avatar
Marko
Posts: 1461
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jan 30th, ’22, 19:59

Thanks, this is very interesting. And which is it, the Selection keys or Ending characters? Or both need to be disabled?

I still wonder why we cannot get this behavior on our systems.
Post Reply