Capitalization not working consistently

Discussion, questions and support.
Post Reply
lwinger
Posts: 6
Joined: Mar 13th, ’18, 03:44

Post by lwinger » Jul 11th, ’20, 05:02

My text expander phrases are not capitalizing as they should or as they have previously. For instance "th" always resulted in "Thanks," but now it is "thanks," in my email program which is Mailbird. It seems to have no problems retaining capitals in Microsoft Word but messes up capitals when triggering an expanded text in a protected sheet in Excel. So in short, it is now hit and miss.

Any help would be appreciated. If it is a result of 4.27, is there a way to roll back to the previous version?
lwinger
Posts: 6
Joined: Mar 13th, ’18, 03:44

Post by lwinger » Jul 11th, ’20, 05:09

I found my own answer. Under "Tools/Preferences/Auto Complete/Options" I de-selected "Correct case of suggested word." Problem solved.
lwinger
Posts: 6
Joined: Mar 13th, ’18, 03:44

Post by lwinger » Jul 13th, ’20, 22:31

I claimed victory prematurely! Any help would be appreciated.
lwinger
Posts: 6
Joined: Mar 13th, ’18, 03:44

Post by lwinger » Jul 14th, ’20, 20:00

For the record, my problem seems to be completely resolved based on this solution posted in the FAQ under Troubleshooting:

In some slower, typically web-based applications, FastKeys key sending can be too fast. In such cases you need to introduce a short delay in Preferences > Text Expander > Advanced. Set a Key Delay to 10-50ms and see if this helps. Key delays can be restricted to certain applications by specifying a list of window titles in which delays will be active.

I added a 10ms delay, and everything seems to work now.
User avatar
Tom
Posts: 398
Joined: Nov 24th, ’15, 23:39

Post by Tom » Jul 15th, ’20, 20:00

I'm glad you found the solution. In which application have you experienced this behavior?
Post Reply