Autocorrect phrase files correcting when not needed.

Discussion, questions and support.
Post Reply
RMDoubleYou
Posts: 11
Joined: Sep 21st, ’17, 21:19

Post by RMDoubleYou » Jan 8th, ’19, 13:22

Hello Fastkeys

I have a problem with the autocorrect phrase files.
Usually it works really well and really quickly which is great.
However there are a few examples when it works against me.

For example when i want to type "for" it corrects "fo" to "of" leading me to type "ofr".
Or when i type want to type "which", fastkeys 'sees' that i typed "whic" and wants to corrects this to "which".
What than occurs is that backspace is pressed and "which" is typed in rapid succession, but i personally also type the last "h".
This ends up with something like "whihch".

One solution to this problem i found myself is to go to the phrase file and change
"::fo::of" to "::fo ::of " (adding a space at the end). I have found that this changes the behaviour of autocorrect to only correct after pressing space. Meaning that weird words like whihch or ofr dont happen anymore.

As you can imagine it is quite tedious to add the space to the end of each word.
Is it possible change the code slightly or change the behavior so that this doesnt occur?
Thank you in advance.

With kind regards,

RMDoubleYou
User avatar
Marko
Posts: 960
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jan 8th, ’19, 17:02

You have the "Trigger immediately" option turned on. For auto-correct this is not advisable.

Select Auto-Correct English file, select More options and disable "Trigger immediately" option. Then the corrects will only be triggered after the ending character is typed (space, comma etc.).
RMDoubleYou
Posts: 11
Joined: Sep 21st, ’17, 21:19

Post by RMDoubleYou » Jan 9th, ’19, 10:48

Hello.

I had this setting indeed and turned it off. But now i noticed another problem.
With the word "column" for example.
When "trigger immediately" is enable, when i type "colum" (without N, without space) it gets corrected to "columN".
So autocorrect works here, but same problem as before.

However if i disable "trigger immediately", "colum" does not get corrected.
As i understand this is ok but it should be corrected as soon as i type "space", even though the entry in the phrase file is "::colum::column::".
Do i understand this correctly?
Neither does "colum " (with space) get corrected.

Is there something i dont understand or do i expect the wrong behavior of autocorrect?
Thanks again for your help. For now i'll keep the option disabled.

With kind regards,
RMDoubleYou
User avatar
Marko
Posts: 960
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jan 9th, ’19, 11:53

Auto corrects trigger after typing the ending character as defined in Preferences/Text Expander. I tried and it works - typing "Colum" followed by Space autocorrects to "Column".

Are other entries working? Maybe you should check your settings, you can also reset the preferences to defaults.
RMDoubleYou
Posts: 11
Joined: Sep 21st, ’17, 21:19

Post by RMDoubleYou » Jan 9th, ’19, 12:19

Ah i found the setting!

i had "Space" disabled in the ending characters settings. This has solved the problem and now autocorrect with the phrase files acts as i expected.
Thank you very much. And thank you for such a quick response!

With kind regards,
RMDoubleYou
Post Reply